Question Re:PS v6.1

Plus d'informations
il y a 3 ans 6 mois #28950 par Laurent Dardenne

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #28974 par Laurent Dardenne
Réponse de Laurent Dardenne sur le sujet Re:PS v6.1
A partir de la v7 preview 1 le cmdlet Send-Mail est considéré comme Obsoléte .
Il n'y a pas de breaking change, sauf si vous considérez ,dans la portée courante, les warning comme bloquant.

Reste à trouver comment on le remplace dans les scripts existant en 5.1...

Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 3 mois #29202 par Laurent Dardenne
Réponse de Laurent Dardenne sur le sujet Re:PS v6.1
v7
via PSSA: Necessary updates for the new ternary operator added in PowerShell languag e

The ternary operator will soon be added to the PowerShell language. Necessary updates may be needed for the PSSA:

New AST type TernaryExpressionAst is added. Changes are made to the visitors in PowerShell. The visitors in PSSA may need to be updated too.


Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 1 mois #29346 par Laurent Dardenne
Réponse de Laurent Dardenne sur le sujet Re:PS v6.1
PowerShell 7 Preview 5 .
Il aura fallu attendre 13 ans pour avoir un cmdlet de compte rendu d'erreur.
Roulez tambours, sonnez trompettes !

Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 11 mois #30235 par Laurent Dardenne
Réponse de Laurent Dardenne sur le sujet Re:PS v6.1
Les prochaines version de PS Core utiliseront à priori .Net 5.0, quelques breaking change à connaitre.

Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 11 mois #30236 par Arnaud Petitjean
Réponse de Arnaud Petitjean sur le sujet Re:PS v6.1
Hello Laurent !

Ca fait plaisir de voir passer un message sur ce forum dis donc ! ;-)

PowerShell 7.1 utilise à priori déjà .NET 5.0. D'ailleurs on devrait peut-être mettre à jour le sujet de ce fil de discussion, non ?

MVP PowerShell et créateur de ce magnifique forum :-)
Auteur de 6 livres PowerShell aux éditions ENI
Fondateur de la société Start-Scripting
Besoin d'une formation PowerShell ou d'un conseil ?

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.073 secondes
Propulsé par Kunena