Question Exécuter BackupAllGPOs.wsf (Résolu)

Plus d'informations
il y a 14 ans 6 mois #696 par Jeel
Hello World,
Je n'arrive pas à intégrer le lancement du script de backup des GPO de microsoft
[code:1](C:\Program Files\GPMC\Scripts\BackupAllGPOs.wsf)[/code:1] dans mon script; PLEASE HELP !

Jeel

Message édité par: Arnaud, à: 18/07/07 14:51<br><br>Message édité par: jeelou2000, à: 18/07/07 15:43

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 14 ans 6 mois #697 par Jeel
Sorry, j'ai trouvé

[code:1]cscript \&quot;C:\Program Files\GPMC\Scripts\BackupAllGPOs.wsf\&quot; E:\BACKUP\GlobalPolicyObjects /comment:\&quot;GPO Backup\&quot;[/code:1]

Jeel

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 14 ans 6 mois #705 par Jacques Barathon
Juste pour préciser: tu n'es pas obligé de mentionner cscript. A priori, l'extension vbs lui est déjà associée, ça devrait donc marcher tout seul.

Par contre, en l'occurrence ton script contenait des espaces dans son chemin complet, donc il fallait bien le mettre entre guillemets, mais alors PowerShell le considérait juste comme du texte à afficher.

Pour préciser à PowerShell qu'il s'agit d'une commande à exécuter, il faut ajouter &amp; devant la chaîne.

[code:1]&amp; \&quot;C:\Program Files\GPMC\Scripts\BackupAllGPOs.wsf\&quot; E:\BACKUP\GlobalPolicyObjects /comment:\&quot;GPO Backup\&quot;[/code:1]
Janel

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.055 secondes
Propulsé par Kunena