Question VSCode & PS7 : Problème de module Microsoft.Online.SharePoint.PowerShell

Plus d'informations
il y a 1 mois 2 semaines - il y a 1 mois 2 semaines #34363 par Durand
Bonjour,

Sur VSCode, si j'installe le module "Microsoft.Online.SharePoint.PowerShell" je ne suis pas capable de me connecter avec.
L'import semble également bizarre.
Un -UseWindowsPowerShell ne fonctionne pas:

import-Module "Microsoft.Online.SharePoint.PowerShell" -UseWindowsPowerShell
Import-Module: Failure from remote command: Import-Module -Name 'Microsoft.Online.SharePoint.PowerShell': Le module « Microsoft.Online.SharePoint.PowerShell » spécifié n'a pas été chargé, car aucun fichier de module valide n'a été trouvé dans un répertoire de module.

Sans, j'ai ce message:

import-Module "Microsoft.Online.SharePoint.PowerShell"
WARNING: The names of some imported commands from the module 'Microsoft.Online.SharePoint.PowerShell' include unapproved verbs that might make them less discoverable. To find the commands with unapproved verbs, run the Import-Module command again with the Verbose parameter. For a list of approved verbs, type Get-Verb

Voici le problème principal que je rencontre où pour lequel j'ai besoin de votre aide 
Si je me connecte avec "Connect-SPOService", il accepte le mdp, je valide le MFA et ensuite j'ai l'erreur suivante:

Connect-SPOService: The remote server returned an error: (400) Bad Request.

Le problème se pose avec VSCode ou directement sur PS 7.

Si j'utilise PS5 avec ISE, je n'ai pas de problème, tout fonctionne correctement.


Le module Microsoft.Online.SharePoint.PowerShell : 16.0.24810.12000
VScode:

Version: 1.89.1 (system setup)
Commit: dc96b837cf6bb4af9cd736aa3af08cf8279f7685
Date: 2024-05-07T05:13:33.891Z
Electron: 28.2.8
ElectronBuildId: 27744544
Chromium: 120.0.6099.291
Node.js: 18.18.2
V8: 12.0.267.19-electron.0
OS: Windows_NT x64 10.0.22631

Ma version de PS 7:

PSVersion                      7.4.2
PSEdition                      Core
GitCommitId                    7.4.2
OS                             Microsoft Windows 10.0.22631
Platform                       Win32NT
PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0…}
PSRemotingProtocolVersion      2.3
SerializationVersion           1.1.0.1
WSManStackVersion              3.0

Dernière édition: il y a 1 mois 2 semaines par Durand.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 2 semaines #34366 par Arnaud Petitjean
Bonjour Durand,

Je n'administre pas SharePoint, donc je n'ai jamais été confronté à ce problème. Cela étant dit, on dirait bien que le module n'est pas supporté avec PowerShell 7.

J'ai d'ailleurs trouvé un fil de discussion sur un forum Microsoft qui semble le confirmer : techcommunity.microsoft.com/t5/windows-p...rshell-7/m-p/3476093.

WARNING: The names of some imported commands from the module 'Microsoft.Online.SharePoint.PowerShell' include unapproved verbs that might make them less discoverable. To find the commands with unapproved verbs, run the Import-Module command again with the Verbose parameter. For a list of approved verbs, type Get-Verb

Ce message est un avertissement qui indique que le module ne respecte pas les bonnes pratiques de nommage. Ce qui est mal, surtout pour un module fait par Microsoft...
Cela dit, je ne suis qu'à moitié surpris car je sais de source sûre que l'équipe Sharepoint a été l'une des dernières à se mettre à PowerShell au sein de chez Microsoft.

Donc, je serai toi, je resterai sous Windows PowerShell 5 avec ce module. Mais cela ne t'empêche pas d'utiliser VSCode. Il faut juste que tu configures ce dernier pour utiliser PowerShell 5 au lieu de PowerShell 7.

Tiens nous au courant.

Arnaud

MVP PowerShell et créateur de ce magnifique forum :-)
Auteur de 6 livres PowerShell aux éditions ENI
Fondateur de la société Start-Scripting
Besoin d'une formation PowerShell ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 2 semaines #34367 par Durand
Merci pour tes recherches.
Comme d'habitude, je cherche une semaine un truc, je trouve rien, je viens sur un forum et dans les minutes qui suivent je trouve la solution...

Finalement j'ai pu l'importer en chargeant sur PS7 directement le .psd1 et en spécifiant le param UseWindowsPowerShell (qui semble être un mode de compatibilité si j'ai bien compris)

Import-Module "C:\Program Files\PowerShell\Modules\Microsoft.Online.SharePoint.PowerShell\16.0.24810.12000\Microsoft.Online.SharePoint.PowerShell.psd1" -UseWindowsPowerShell

Par contre ca pète totalement la complétion
mais les commandes sont fonctionnelles et je peux rester sur PS 7 

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 2 semaines #34368 par Arnaud Petitjean

Comme d'habitude, je cherche une semaine un truc, je trouve rien, je viens sur un forum et dans les minutes qui suivent je trouve la solution...
 

Tu viens sur un forum !? Non, pas vraiment... Tu viens sur LE forum START-SCRIPTING.COM c'est pas du tout pareil !! 

Effectivement le paramètre -UseWindowsPowerShell de la commande Import-Module est un mode de compatibilité de PowerShell 7. En réalité ça va te démarrer et exécuter tes commandes dans PowerShell 5 et te ramener le résultat dans PowerShell 7. C'est de la proxyfication. Je trouve que c'est un peu usine à gaz mais ça doit pouvoir rendre service.

Plus d'infos ici (en français !) : learn.microsoft.com/fr-fr/powershell/mod...?view=powershell-7.4

Arnaud

MVP PowerShell et créateur de ce magnifique forum :-)
Auteur de 6 livres PowerShell aux éditions ENI
Fondateur de la société Start-Scripting
Besoin d'une formation PowerShell ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 2 semaines #34377 par Durand
Si d'autre personne ont le soucis, je précise qu'un simple:

Import-Module "Microsoft.Online.SharePoint.PowerShell" -UseWindowsPowerShell

N'est pas fonctionnel chez moi, j'ai du mettre le chemin complet du psd1 (voir mon précédent post)

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.111 secondes
Propulsé par Kunena