Résolu script à exécuter sur tous les postes

Plus d'informations
il y a 1 mois 3 semaines - il y a 2 semaines 4 jours #33861 par rhiwotar
Bonjour à tous et bonne année !!

Petit souci avec un script rebelle, 
D'habitude, mes scripts sont dans les GPO pour une exécution au démarrage.

Celui là se lance bien (mes logs le confirme) mais une partie ne passe pas.
Ce même script lancé manuellement s'exécute parfaitement sur un pc qui n'en à pas voulu en auto.

Je voudrais savoir s'il y à des façons de lancer un script à distance
enter-pssession la prise en main marche mais depuis le poste, ne marche pas, erreur d'autorisation
invoke-commande ne marche pas, erreur non spécifié

Avez-vous d'autres méthodes sous le coude? j'ai la moitié de mon parc qui est passé à travers le filet et de ce script dépend une mise en prod que j'ai commencé hier 

Merci d'avance!! 
Dernière édition: il y a 2 semaines 4 jours par rhiwotar.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 semaines #33862 par ericlm128
Via ton outil de déploiement d'application habituel.
Chez nous c'est SCCM (Configuration Manager)

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 semaines #33863 par rhiwotar
euh... mon outil de déploiement d'application habituel s'appelle "install de base.ps1"
On s'amuse bien chez nous 

On va mettre en place InTunes sous peu mais jusque là, la direction était un petit peu retissant à prendre une licence pour ça quand un brillant, talentueux et magnifique Maitre PowerShell travaille pour eux et peux tout faire comme par magie et "gratuitement" (je coute cher en chocolat)

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 semaines #33866 par Arnaud Petitjean
Hello et bonne année !! Que celle-ci soit prolifique en termes de création et de qualité bien sûr ! ;-)

Pourrais-tu nous dire ce que fait ton script ?

Je pressens un problème de double saut ("double hop issue", dans la langue de Shakespeare). Cela se produit si tu essaie d'accéder à une ressource réseau à partir d'une machine distante. Il s'agit d'un problème d'authentification et de ticket Kerberos. En effet, celui-ci ne permet pas la réauthentification, du coup tu dois recevoir un message d'erreur de type accès refusé ?
Dis nous si c'est le cas, car en en fonction on avisera. Il n'est pas évident de contourner cette limitation volontaire des privilèges imposée pour des raisons de sécurité. Et il y a surtout plusieurs façons de faire en fonction des cas.

Arnaud

MVP PowerShell et créateur de ce magnifique forum :-)
Auteur de 6 livres PowerShell aux éditions ENI
Fondateur de la société Start-Scripting
Besoin d'une formation PowerShell ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 2 semaines #33877 par rhiwotar
Bonjour!!

Le script est très simple, il est exécuté par le poste et récupère les drivers d'impressions pour les installer sur le pc.
Si je le laisse faire, il s'exécute sur 60% de ma flotte mais j'aimerais le lancer de force.
J'ai pourtant pas l'impression d'avoir un double bond ou alors c'est implicite dans une commande

(A part les logs, c'est le script complet)
$serveur = "srvimprimante"
    $Listeprinter = get-printer -ComputerName $serveur
    foreach($printer in $Listeprinter){
        Clear-Variable driver,chemin -ErrorAction SilentlyContinue
        $driver = Get-PrinterDriver -ComputerName $serveur -name $printer.drivername|select -last 1|where{$_.InfPath -notlike $null}
        if(((Get-PrinterDriver).name -notcontains $driver.name) -and ($driver.infpath -notlike $null)){
            $tmpc = "C:\"
            $tmpsrv = "\\$serveur\c$\"
            $chemin = $driver.InfPath.replace($tmpc,$tmpsrv)
            pnputil.exe -i -a $chemin
            Add-PrinterDriver -Name $printer.drivername -ErrorAction SilentlyContinue
        }
    }

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 1 semaine #33882 par Arnaud Petitjean
Hello Rhiwotar !

Je persiste à penser qu'il est très probable que tu sois face au problème de double saut. 
En effet, en regardant ton script, on voit que tu dialogues avec une machine distante (ton serveur d'impression). Et ton message d'erreur est clair, tu as un problème d'authentification ou d'accès.
Donc finalement c'est assez logique.

De plus, cette ligne a un problème :
$tmpsrv = "\\$serveur\c$\"# devrait être écrite ainsi$tmpsrv = "\\$serveur\c`$\"
Il faut ajouter le caractère "accent grave" aussi appelé "backtick" pour que le $ ne soit pas interprété comme une variable.

Mais à cause du problème de double saut, même si tu corriges le bug, je pense que ça ne fonctionnera pas.

Concernant l'évitement du pb de double saut, il y a plusieurs moyens de le résoudre, on pourra en reparler car le sujet est assez complexe.
En attendant, je t'invite à lire cette fiche :  Making the second hop in PowerShell Remoting - PowerShell | Microsoft Learn

Arnaud

MVP PowerShell et créateur de ce magnifique forum :-)
Auteur de 6 livres PowerShell aux éditions ENI
Fondateur de la société Start-Scripting
Besoin d'une formation PowerShell ?

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.297 secondes
Propulsé par Kunena