Résolu [RESOLU]Package provider probleme de version

Plus d'informations
il y a 1 semaine 3 jours #31494 par rhiwotar
Bonjour à tous !

Ce matin, petit problème avec l'installation de mes packages, j'ai voulu installer adobe 
Install-Package  -Name adobereader -Force
mais résultat
AVERTISSEMENT : NuGet: System.InvalidOperationException: Unable to find version '1.0.20160915' of package 'KB2919442'.
AVERTISSEMENT : NuGet:    … NuGet.PackageRepositoryHelper.ResolvePackage(IPackageRepository sourceRepository, IPackageRepository localRepository, IPackageConstraintProvider constraintProvider
, String packageId, SemanticVersion version, Boolean allowPrereleaseVersions)
AVERTISSEMENT : NuGet:    … NuGet.PackageManager.InstallPackage(String packageId, SemanticVersion version, Boolean ignoreDependencies, Boolean allowPrereleaseVersions)
AVERTISSEMENT : NuGet:    … NuGet.Commands.InstallCommand.InstallPackage(IFileSystem fileSystem, String packageId, SemanticVersion version)
AVERTISSEMENT : NuGet:    … NuGet.Program.Main(String[] args)
AVERTISSEMENT : NuGet: System.InvalidOperationException: Unable to find version '1.0.20160915' of package 'KB2919355'.
AVERTISSEMENT : NuGet: System.InvalidOperationException: Unable to find version '2021.007.20099' of package 'adobereader'.

j'ai vu que nuget était en version 6 (recommandé 5.10) alors que sur mes pc, ils sont en 2.8.5.208, serai-ce celà? je trouve pas comment le mettre à jour
j'ai passé nuget et chocolatey en trusted, j'ai même indiqué le provider chocolatey mais ça me pose quand même le problème de nuget
Install-Package -ProviderName chocolatey -Name adobereader -Force

Avez-vous une idée?
Merci d'avance

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 semaine 3 jours - il y a 1 semaine 3 jours #31495 par Laurent Dardenne
Salut,
une piste à étudier : stackoverflow.com/questions/61029181/war...nals-with-powershell

Peut être un pb avec TLS 1.3 ...

Concernant le msg d'erreur je ne sais pas si c'est le package qui est erroné ou la recherche des dépendances.

Tutoriels PowerShell
Dernière édition: il y a 1 semaine 3 jours par Laurent Dardenne. Raison: coquille

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 jours 9 heures #31508 par PatriceLT
As tu résolu ton problème ?

Si tu ne l'as pas encore résolu, as-tu vérifié que tu avais bien les KB d'installé (le numéro se trouve dans le message d'erreur), je pense qu'il y'a des dépendances pour NuGet qu'il faut avoir en prérequis.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 jours 9 heures - il y a 3 jours 9 heures #31515 par rhiwotar
Bonjour,

Désolé pour la réponse tardive,

C'était bien ça, une petite modif des reg pour prendre en compte le TLS 1.3 et c'est parti !!
Pour les KB, ce sont bien des dépendances que nuget installe par lui même

Merci à vous!!!
Dernière édition: il y a 3 jours 9 heures par rhiwotar.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.080 secondes
Propulsé par Kunena