Question Insérer une formule excel

Plus d'informations
il y a 3 semaines 2 jours #30749 par kroum
Insérer une formule excel a été créé par kroum
Bonjour,

Je souhaite insérer une formule excel dans une cellule et sans succès, j'ai testé avec le caractère d'échappement à plusieurs endroits rien à faire
Serailt il possible de m'aider ?
l'erreur est sur la dernière ligne
Merci
#Création du fichier excel
#pour démarrer excel

$excel = new-object -comobject Excel.Application
#Pour qu'il soit visible à l'écran =$true sinon $false
$excel.visible = $true
#Pour ne pas afficher les avertissements
$excel.DisplayAlerts = $false

##création du classeur
$WorkBook = $Excel.Workbooks.Add()
$WorkBook.SaveAs("D:\tt.xlsx")



#Création de la feuille All vms
$WorkSheet = $WorkBook.WorkSheets.Add()
$WorkSheet.name = "All Vms"

#Mise en page de la feuille all vms

$WorkSheet.Cells.Item(1,1) = "Sam"
$WorkSheet.Cells.Item(2,1).formula ="=NB.SI(A3:F7;"*.vib")"

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 semaines 2 jours #30750 par Laurent Dardenne
Réponse de Laurent Dardenne sur le sujet Insérer une formule excel
salut,
as-tu essayé de doubler les guillemets ou une Here-String ?

$WorkSheet.Cells.Item(2,1).formula =@'
=NB.SI(A3:F7;"*.vib")
'@

Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 semaines 2 jours #30753 par kroum
Réponse de kroum sur le sujet Insérer une formule excel
j'ai testé le here-string et doubler les guillemets ça ne fonctionne pas
avec le here string, la formule s'inscrit mais n'est pas reconnu en tant que formule

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 semaines 2 jours #30754 par Laurent Dardenne
Réponse de Laurent Dardenne sur le sujet Insérer une formule excel
En vérifiant le contenu après avoir inséré manuellement la formule, la syntaxe différe de celle affichée/insérée :

Formula : =NB.SI(A3:F7,"*.vib")
FormulaArray : =NB.SI(A3:F7,"*.vib")
FormulaLabel :
FormulaHidden : False
FormulaLocal : =NB.SI(A3:F7;"*.vib")
FormulaR1C1 : =NB.SI(R[1]C:R[5]C[5],"*.vib")
FormulaR1C1Local : =NB.SI(R[1]C:R[5]C[5];"*.vib")

En remplaçant le point virgule par une virgule l'affectation réussi, je te laisse vérifier si elle est fonctionnelle :
$WorkSheet.Cells.Item(2,1).formula ='=NB.SI(A3:F7,"*.vib")'

Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 semaines 2 jours #30759 par kroum
Réponse de kroum sur le sujet Insérer une formule excel
Merci ça fonctionne à moitié mais ça me va
je dois aller sur la cellule , et cliquer sur valider
excel me corrige a formule

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.155 secondes
Propulsé par Kunena