Question TS Environnemnt et caractères accentués

Plus d'informations
il y a 3 ans 5 mois #29033 par Besançon Ludovic
Bonjour,

J'utilise MDT avec des scripts powershell.
J'ai un problème d'accent.
Dans mon interface j'ai défini un role avec pour valeur \"Privé Drirection Financière\"
Dans un script powershell, dans une étape du déploiement, je peux récupérer la valeur du role avec les instructions :
[code:1]$myTSEnv = New-Object -ComObject Microsoft.SMS.TSEnvironment
$myRole = $myTSEnv.value(\"Role001\"«»)[/code:1]
Cependant j'obtiens : Privé Direction Financière

Sauriez-vous m'aider à obtenir la valeur correcte ?

Merci.

Ludovic.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #29034 par Arnaud Petitjean
Bonjour Ludo,

Tu obtiens ces caractères bizarres à quel moment ? Lors de l'affichage du résultat dans la console PowerShell ?

Quelle version de PowerShell utilises-tu ? Avec quel éditeur as-tu écrit ton script ?

Vérifie le format d'encodage de ton script.

Je sais c'est beaucoup de questions mais il est important que tu y répondes afin que l'on puisse t'aider.

Merci

MVP PowerShell et créateur de ce magnifique forum :-)
Auteur de 6 livres PowerShell aux éditions ENI
Fondateur de la société Start-Scripting
Besoin d'une formation PowerShell ou d'un conseil ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #29035 par Besançon Ludovic
En fait j'inscrit la valeur dans le registre par :
[code:1]Set-ItemProperty -path HKLM:\Software\BC\Configuration\MDT -name Rôle -value $myRole[/code:1]
Et je retrouve donc ma valeur dans le registre.

Je déploie du Windows 10, la version du powershell est 5.1.17763.503

J'utilise UltraEdit pour mes scripts ...

Ludovic.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.074 secondes
Propulsé par Kunena