Question Difference de resultat avec le même script

Plus d'informations
il y a 7 ans 1 mois #17348 par Eric
Bonjour,

Voilà mon problème :

je lance un script à partir d'un serveur 2008 avec un environnement Powershell 3.0 et je lance exactement le même script à partir d'un Windows 7 pro avec un environnement Powershell 3.0 et les résultats sont différents...

Je récupère des variables d'une base de registre d'une machine distante.

$Reg = [Microsoft.Win32.RegistryKey]::OpenRemoteBaseKey('LocalMachine',$Server)

$RegKey= $Reg.OpenSubKey(\"SOFTWARE\\McAfee\AVEngine\")
$AVDatDate = $RegKey.GetValue(\"AVDatDate\")
$AVDatVersion = $RegKey.GetValue(\"AVDatVersion\")

Typiquement je récupère moins d'info avec Windows 7 car sur certaine machine, ca marche aussi avec windows 7.

Le compte qui lance le script et le même dans les 2 cas et les cibles aussi.

Si vous avez une idée, je suis preneur.

Merci de votre aide

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 1 mois #17351 par Laurent Dardenne
Salut,
Fernandes écrit:

Typiquement je récupère moins d'info avec Windows 7

En les visualisant, via regedit par exemple, toutes les infos attendues sont bien présente ?

Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 1 mois #17361 par Eric
Oui, Je récupére la valeur de la variable lorsque je lance le script avec windows server 2008 mais lorsque je lance le même script avec windows 7 ça n'affiche rien et aucune erreur.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 ans 1 mois #17363 par Laurent Dardenne
Si tu n'as pas d'erreur, je suppose que l'API te renvoi une clé vide, dans ce cas recherche plutôt du côté du framework .
Les postes qui posent pb sont en 32 ou en 64 bits ?

Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.124 secondes
Propulsé par Kunena