Question Modification massive d'attributs

Plus d'informations
il y a 8 mois 2 jours #29366 par Wbishop13
Mateu, autant pour moi, j'ai pris le mauvais screen, de mémoire, ça fait pareil en copiant collant le votre, je verifie demain en arrivant au bureau (peu de temps à consacrer à cette tâche pour el moment désolé de pas être plus réactif)

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 1 jour #29367 par Wbishop13
Voilà l'erreur en utilisant exactement votre script

www.noelshack.com/2019-44-3-1572452255-2...ndows-powershell.jpg

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 1 jour #29368 par matteu
Réponse de matteu sur le sujet Re:Modification massive d'attributs
Pouvez vous tentez de lancer le script depuis un powershell ISE et non pas depuis la console que vous utilisez actuellement ?

On dirait qu'il ne parvient pas à lire le fichier CSV. Etes vous bien certain de l'emplacement ?

De mon côté ça fonctionne très bien donc je vois pas vraiment ce qui ne va pas :/

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 1 jour #29370 par Laurent Dardenne
matteu écrit:

Pouvez vous tentez de lancer le script depuis un powershell ISE et non pas depuis la console que vous utilisez actuellement ?

Je préconise tjr l'inverse, ISE est un host différent d'une console qui est plus 'proche' du runtime Powershell ( moins de particularité).
matteu écrit:

On dirait qu'il ne parvient pas à lire le fichier CSV. Etes vous bien certain de l'emplacement ?

Le msg d'erreur serait différent, ajoute un Write-debug/ou write-warning dans la boucle foreach.
[code:1]
Write-Warning \"$($_|select *|out-string)\"
[/code:1]
Vérifie le contenu de ton fichier csv, un champ vide n'est pas une chaine vide.

Tutoriels PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 mois 6 jours #29485 par Wbishop13
Bonjour à tous! Suite à toutes vos explications, le problème est résolu, je n'étais pas dans le bon invite de commandes.

Merci à tous pour votre aide précieuse!

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.232 secondes
Propulsé par Kunena